Missing User Attribute Information After OIDC Login

Overview

This article explains why user attributes are missing from a user profile after a login using an OpenID Connect (OIDC) connection. This issue occurs when information from the Identity Provider (IDP) is not included in the user’s profile, leading to the following warning in the system logs:

Error transforming template due to missing keys (X) from IdP context

Applies To

  • OIDC Connections

Cause

The warning message appears because one or more expected attribute keys are not present in the context provided by the IDP during the user login or signup event.

Solution

To identify the specific attributes that are missing from the IDP context, follow these steps:

  1. Navigate to the warning log entry that corresponds with the user event (for example, login or signup).
  2. Select the Open Details option at the bottom of the log entry.
  3. In the JSON object details, locate the details array. The missing attributes are listed in the missing_keys array.