[minor] autocomplete password attribute warning for the Universal login

Getting this warning in Chrome Devtools

[DOM] Input elements should have autocomplete attributes (suggested: “current-password”): (More info: https://goo.gl/9p2vKq) <input class=​"input _input" name=​"password" id=​"password" placeholder=​"Password" type=​"password" aria-label=​"Password" required>​

Also, is there a way to set the favicon?

Hi @Civility,

Sorry for the delayed response.

I wasn’t able to reproduce the autocomplete warning, let me know if this is still effecting you and the steps to reproduce.

You can set the favicon for the new universal login via the branding API:

Thanks @dan.woda, the autocomplete warnings are gone!

As for the favicon, I’ve logged into the Branding API page,

Filled in the parameters with

{
  "favicon_url": "https://web.civility.social/icons/icon-48x48.png",
}

Clicked TRY, and I get an error that I’m not authenticated:

I assume that request should have worked since I’m authenticated and an admin? Otherwise, why let authenticated users spend time crafting request parameters in those boxes.

UPDATE

Turns out I had to get yet another token, in order to try that request. Now there’s a new error I’m getting:

{
  "statusCode": 400,
  "error": "Bad Request",
  "message": "Invalid request payload JSON format"
}

The documentation states that both strings are optional:

image

I only wanted to change the favicon_url.

Suggestions:

  1. Make setting the favicon easier. After all, it’s one textbox for the link. Can be placed next to where the logo URL is set.
  2. If a favicon is not supplied, default to a resized version of the logo.
  3. Make the branding PATCH request accept only one parameter.
1 Like

Hi @Civility,

It looks like there might be an unnecessary comma in your JSON that is causing the error. I tried it and am not getting the error after removing the comma.

Like this:

{
  "favicon_url": "https://web.civility.social/icons/icon-48x48.png"
}

Thanks for all the constructive feedback!

1 Like

I sent the feedback you left to our product team. They will contact you if they have any more questions.

Thanks again,
Dan

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.