MFA - Can't activate MFA email factor


I’m trying to activate the MFA email factor on my Auth0 setup but I can"t achieve it.
I have:

  • Enabled email factor in (OTP and SMS are also activated)

  • Set the Require Multi-factor Auth policy to never

  • I’m using the New Universal Login

  • Created a rule to activate MFA on a dedicated application
    function (user, context, callback) {

    if (CLIENTS_WITH_MFA.indexOf(context.clientID) !== -1) {
      context.multifactor = {
        	provider: 'any', // Require MFA with any provider enabled in the dashboard
       	 //allowRememberBrowser: false // Uncomment to disablle Remember Me MFA feature
    callback(null, user, context);


  • Setup Sendgrid configuration for the mail sent

When I try to authenticate the MFA page first propose me the OTP factor, and when I click on “use another method” it’s only displaying Google-Authenticator (OTP) and SMS, not email.

Can you help me how to fully setup email factor?

Hi @brice.santus,

Welcome to the Community!

Can you confirm the following:

Hi @dan.woda!

Thanks for your answer.
I confirm that the app is using New Universal Login, Email is enabled and user mail is verified.
I finally get access to email factor during a login but only after having login once with another MFA factor.

Is it possible to filter the list of available factors per user? For example I want user A to be able to use OTP and SMS and user B to be able to use OTP and Mail.

Thanks a lot for your feedback

Not at this time. Can you expand on the use-case for this? I would be happy to pass the request along to our product team.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.