Auth0 Home Blog Docs

Logout redirect urls

logout
redirect

#1

after the logout redirect, i’m getting the “Oops!, something went wrong” auth0 error page.

in my client settings page, under logout urls i have
http://localhost:9801

my auth0 logout link is https://mydomain.auth0.com/v2/logout?returnTo=http%3A%2F%2Flocalhost%3A9801"

what am i doing wrong?


#2

Jon,
Have you tried adding a index.html or page to see if that works. It might be possible that the parsers don’t know your page is as that is the actual BASE URI


#3

i think something is up with my settings and not the local webserver.
i come to this conclusion because other clients do work, and this client with these settings do not.


#4

The redirect after a logout is dependent on whether you are passing a client_id parameter to the logout endpoint.

As can be seen from your logout URL, you are not passing a client_id parameter, hence you need to set the Allowed Logout URL at the account level.

If passing the client_id parameter to the logout endpoint, you need to set the Allowed Logout URL at the client level.

The logout functionality is outlined in the following document:

https://auth0.com/docs/logout


#5