Logout redirect fails

logout redirection fails even though I have listed the redirect url under the application Allowed Logout URLs.

The “returnTo” querystring parameter is not defined as a valid URL in “Allowed Logout URLs”. To add a new URL, please do it here: https://manage.auth0.com/#/account/advanced

I have added the logout url to the allowed logout urls and it makes no difference

how can I find out why this is failing?

This is the redirect code:

this code has worked in the past, so it must be a configuration error, I don’t know what else I can do beyond adding the url to the allowed logouts

Since this allowed logout functionality appears to be insufficiently documented or buggy, is there anyway to disable it?

@chris11 there are a couple of things you should check, based on the documentation:

  1. Although you are URL encoding the returnTo parameter, the URL you use in the Allowed Logout URLs should be the non-encoded URL.
  2. As you are not passing a client_id parameter in your /logout call, the URL needs to be whitelisted at the tenant level, rather than at the application level. You can add the URL to your tenant-level Allowed Logout URLs from the tenant settings.

The following documentation outlines the above in more detail:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.