Login with multiple connections break when using organisation invite email

Hi there!

I’m dealing with various organizations and custom logins for such. I have an admin interface which let’s me create users. On creation I send an Invitation Email for a specific organization. Each organization has:

  • a specific Database (Email + Password Auth) connection
  • social connections

Everything works fine so far. The user receives an email and when clicking on it the user lands on my custom login page which redirects to the New Universal Login Page for the organization. I do this with

loginWithRedirect({ organization: orgId, invitation: inv })

When redirected the user sees the Universal Login Page for the organization with

  • Username + Password (the email is already pre-filled in the email field)
  • and Social Logins which are defined for this organisation

Unfortunately, the user cannot decide wether he want’s to sign up with a social login OR username + password but has to deal with whatever connection comes first in the list of connections for this organization!

I know that loginWithRedirect and the /invitation endpoint accept the connection parameter which would force a connection the user has to login with. But if this is the desired workflow, why do we even have the connection_id parameter optional? Why does the login screen even show the social logins for this organization?

Do I get something wrong here?


Hi @Poolshark ,

In my testing, after providing the generated invitation code and org ID to an /authorize call I was directed to the “You’ve been invited!” page and was given the choice to sign up with email and password or “Continue with Google” as I had not passed a connection_ID when generating the invite, and these were the two enabled connections for my Organization “Org1”:

Please also note that the user must use the same email address as was specified on the invite, this is mentioned in the “Limitations” note on this page:

When I passed a connection_id to the invitations endpoint, my database connection in this case, I no longer saw the Google option as expected:

So as far as I can tell this is working as expected, are you perhaps sending a connection ID when you didn’t intend to?



Sorry for my late reply & thanks for your answer!

It was my mistake since I was trying to use more than one database connection for one organization. Since I got rid of this, it works all fine!

1 Like

Wohoooo! Glad to hear that!

1 Like