Liquid page templates for Universal Login not parsed

Hi there,

I’m trying to implement the universal login templates with the Liquid template language. I already setup a custom domain (and use that for authenticating), and am able to successfully publish my templates through CLI.

However, when I try to login I notice that the Liquid is not parsed (I am viewing this on my own custom domain, not *.auth0.com). I’ve tried everything from Googling, to looking through the settings to reading this forum. Also created a ticket at Auth0, but no one responded there yet.
Since my team is stuck with this, I thought I’d try the forum :wink: There’s multiple similar questions in the forum, but none seem to have a complet answer written down in the forum.

Hoping anyone can help me with this.

A screenshot of what I see (the “well hello” text is added by myself, the rest is the default basic example shown in the docs):

Thanks,
— Jeroen.

@jeroen.reumkens,

Welcome to the Auth0 Community!

I reached out to you in response to your Twitter DM.

It’s best to let our support team handle it so we aren’t doubling/tripling our efforts on the same issue. I’ll update this thread when we have an answer.

If you have an urgent issue, please mark the ticket ‘Urgent’ so we know you require an immediate response.

Please see this doc for more info:

Hi @dan.woda

Thanks for your response! Sorry for pushing a bit on this. 24 hours was indeed pretty long for being stuck as a paying customer :sweat_smile: Support is still helping me with this. We’ve already found some sort of solution, and are trying to improve it.

As for anyone reading this, a short description of the issue and possible solutions we have until now:

I am using the Auth0 Deploy CLI: https://github.com/auth0/auth0-deploy-cli/
If you use that tool, then somehow it won’t update your templates in the correct way, and thus not parse the templates. Support tells me it should update though, but as for me that’s not (yet) working.

The current solution I settled on for now is using the API itself to update the template: Auth0 Management API v2

However, when I tried that at first it still wasn’t working. The issue lied in the toggle below to enable the custom login page. If you ask me the title of that option is confusing. I had this option enabled, because I do want to customize the page. However, what this toggle actually means is “Do you want to customize the login page via the editor below?”. Because if you enable the toggle, it will still update your uploaded code via CLI, but not parse it. And if turn the checkbox off, the template will still be uploaded via the CLI and will be used, but it will also parse the Liquid code. So even though the toggle is off, you still use your custom template, and it’s actually the only way to use it if you need the Liquid to be parsed.

Hopefully this makes sense to anyone struggling with the same issue :smiley: If Support get’s back to me with more info on why the Deploy CLI doesn’t work I’ll make sure to post it here as well.

Cheers!

1 Like

I’m going to add some context here for future users:

The “Customize Login Page” code box seen here is only for Classic Universal Login only.

It does not accept the New Universal Login Customizations like the {%- auth0:widget -%} liquid templating. In order to update this, you need to use the Page Templates API.

1 Like

I’m going to mark this solved as it looks like the support case is complete. Thanks

1 Like

Yes, totally right! My addition to that is that if you still leave the toggle ‘customize login page’ enabled, you will see the template you uploaded via CLI in the editor below the toggle, but it will not parse the Liquid.

So in order to have the liquid parsed, the toggle should be OFF. That’s not immediately clear looking at the page, and is not clearly (at least not to me) mentioned in any of the docs.

I agree, it’s confusing. I’ll create a ticket with our docs team to try and clarify this one. Thanks for the feedback!

Also to help clarify, the code in the grayed-out code box here is not being parsed. You should be able to put anything in that box and it won’t have an effect if the toggle is turned off.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.