Auth0 Home Blog Docs

Laravel: "Service not enabled within domain"

We are going to be using Auth0 for our Laravel application. Another developer has set up our official account and has it working, but the environment file he uses is, of course, not part of the checked in code and I haven’t been able to talk to him about what he actually did. I don’t have any information about the official Auth0 account at this time.

Right now, I just want to do the minimum changes to the application in my VM so I can bypass the security and work on the parts I am supposed to be doing.

I created a personal account and tried to follow the instructions here: https://manage.auth0.com/dashboard/us/dev-ch81jf98/applications/28ALoSAVBUOKeph9ZVQoTiBdKpLSFQp7/quickstart

Currently I am getting the error:
Client error: POST https://<my auth0 domain>.auth0.com/oauth/token resulted in a 403 Forbidden response:\n {“error”:“access_denied”,“error_description”:“Service not enabled within domain: http://localhost:8080/”}\n

http://localhost:8080/ is listed in the Allowed Web Origins. In fact, I’ve set it to:
http://localhost:8080/,https://localhost:8080/,https://localhost:8080,http://localhost:8080 just to cover all the bases.

Ideally, we would like to have a configuration that would always return authorized and preferably doesn’t even go to the Auth0 web site for our development VMs since some of our development set ups have extremely limited access outside of our lab. My current system can get to the auth0 web server, but that may not always be the case. My searches indicate that we should be able to configure this, but I haven’t figured out exactly what the settings need to be. I looked at https://auth0.com/docs/dev-lifecycle/local-testing-and-development and I have set my callback URL to https://localhost:8080/auth/callback but that didn’t seem to help.

UPDATE: I added http://localhost:8080/auth/callback to my callback URL and it is no longer throwing the exception.