Laravel 10 and Auth0 not working

i am using laravel 10 and trying to get auth0 to work.
The auth0 version is: auth0/login: ^7.5

I have tried to reproduce the steps on the page GitHub - auth0/laravel-auth0: Laravel SDK for Auth0 Authentication and Management APIs.

Currently I get the error message:
Auth driver [auth0] for guard [auth0] is not defined.
What might I have forgotten?
I would like to see step-by-step tutorials on the auth0 site again. Unfortunately, there are currently only projects that cannot be clearly understood.

1 Like

I was facing the same issue with version 7.5.0 in my laravel application.
I had to downgrade back to version 7.4.0 of auth0/login.

1 Like

this will help you

that does not help.
With a new Laravel project and the instructions, the same error message always comes up. Either it is due to the PHP version or the instructions are not complete.

1 Like

The instructions are probably outdated.

In providers:

    'auth0' => [
        'driver' => 'auth0.provider',
        'repository' => \Auth0\Laravel\Auth\User\Repository::class

In guards:

    'auth0' => [
        'driver' => 'auth0.guard',
        'provider' => 'auth0',
1 Like

Thank you very much!
That is the solution!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.