Issues with adding Auth0 Vault Connection

Hello, I have built a customised Onboarding form based on the template provided by Auth0.

Now I am struggling with adding a vault connection, I have created a M2M Application which is authorized to use my custom API with all the needed scopes.

The error I am getting indicates that I am using the wrong credentials.

I have copied the domain, client id and client secret directly from the settings tab.
I have read about other users accidentally using the wrong application type, but I am more than sure I use a M2M App.

I’ve been trying around for pretty long already, I can’t seem to find whats wrong.

I appreciate any help, thanks!

Hi @niklas.michel

Welcome to the Auth0 Community!

Thank you for posting your question. I’ve checked your tenant settings and logs, and I think that this issue can be caused by your M2M not being privileged to the Management API. It’s necessary to authorize the Auth0 Managment API application.

If you want to use your owned API from Vault view, you can select HTTP, but it’s only support access token for now.

I hope this will help you!


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.