Auth0 Home Blog Docs

Invalid token when using newly created token with Management API docs

I’m attempting to use the “try” functionality in the Management API documentation at https://auth0.com/docs/api/management/v2. Per the instructions at https://auth0.com/docs/api/management/v2/get-access-tokens-for-test, I’m supposed to obtain an API explorer token at the indicated page in my profile. Back in the Management API documentation, I clicked the “Set API Token” button and pasted in my token, and it recognized the domain from that correctly.

When I then attempted to list all the users, I clicked try and received a 401 indicating that I used an invalid token.

I’ve tried this token on several other commands on the page and have tried regenerating the token, all to no avail. What’s going on and how might I get this to work?

Thanks!

To follow up, I’ve also attempted to use this token within Postman with the same domain and I’m seeing the same thing - a response of a 401 indicating that it’s an invalid token.

Hello @whit.waldo,

If you go to “APIs -> Auth0 Management API -> Machine to Machine Application” and the expand the “API Explorer Application”, does the API Explorer Application have the read:users scope enabled?

1 Like

That did the trick - thank you!

2 Likes

Thanks @markd a lot for help on that front! Great you have it now working @whit.waldo!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.