Id_token not present in TokenSet // tenant must be specified

I’m using Next.js and ‘@auth0/nextjs-auth0’ library, my application works very well on the local environment, but when I moved to staging/production this endpoint https://my-domain/api/auth/callback?code=some token returns a 400 with response id_token not present in TokenSet.

Also when I tried using the password change flow, I got an error {"name":"BadRequestError","code":"missing_property","description":"tenant must be specified","statusCode":400} when I completed the password change and it is time to get redirected.

The only thing that changed since the last time it worked is that we changed our base url to a subdomain, which has been updated across all environments. I saw solutions around openid profile and I can say I have configured that right too.

Please any help will be great.
Moxie.

Hi @moxie.dee

Welcome to the Auth0 Community.

Another user had a similar issue here https://community.auth0.com/t/id-token-not-present-in-tokenset/63690

Please can you review and see if this applies to your case.

Warm regards.

1 Like