Auth0 Home Blog Docs

I am not getting userinfo both via my app and postman ! What's going on?

userinfo

#1

I want to get user info but I am failing to get data. I few hours ago I was be able to get just de meta data of the user by doing get to /userinfo but now I am getting nothing. I just don’t know what’s going on ? thoughts


#2

What scopes are you requesting? I’d suggest going with openid profile email for debugging this.


#3

In my app I use openid profile email , is this the right way to test that with postman? I do the following


#4

You need to request those scopes when you’re getting your token, not when calling userinfo.

Can you tell me something about your app? How are you authenticating? If you’re using Auth0.js, or a similar client, you should be able to add a scope parameter.


#6

Hey there @pathmanshakir!

As @thijmen96 said, you don’t do this directly in Postman, you need to request those scopes when you’re getting your token. Please let us know how you authenticate and what client do you use.

Thanks!


#7

This is how I get the access token, I also tried to with just “openid profile email” and that also didn’t work.


#8

I am experiencing some strange things, I just don’t understand it anymore.
I getting the userinfo now but not metadata… I already have a rule for it and it worked fine last week, but now I am not getting the metadata. This is the rule.


#9

I’m going through your screenshots right now. Will comment on them in a minute.Btw. can you provide us with code snippets instead of screenshots as it will be easier for us to inspect, thanks a lot! You said you were able to retrieve data calling userinfo endpoint. Have you changed something since then or it just stopped working?


#10

I just created a new application in auth0 and used the credentials. I will try to provide with code snippets but next time. but at the moment the only problem is that I can’t get the meta_data on postman. I used this claim last week and it was working fine but it’s not working now. I read that I have to inculde the metadata in the scope… would that be my solution ? and how should I include that in scope … I don’t understand that, shall I mentioned it somewhere with " openid profile email “”


#11

@pathmanshakir can you let me know if the scenario once you created a new app now is the same? Have you been able to get the metadata at the beginning and then without changing any of the code you’re not able to? Is that correct?

You don’t need to include the metadata in the scope. Scope is a parameter you need to specify in order to be able to retrieve the exact userinfo data that you want. Please let me know the answer to the above question and we’ll be able to investigate it further.

Thanks for clarification


#12

The porblem has been solved, I was working in my branch on a project and after merging with master I faced this problem. The wronge line of code was seleected during he merge conflict. Thanks for your reply.


#13

Thanks for sharing that with the community!