Auth0 Home Blog Docs

How to skip "consent_required"


#1

I implemented Auth0 as below

const authInit = new auth0.WebAuth({
          domain: authConfig.domain,
          clientID: authConfig.clientId,
          redirectUri: authConfig.callbackUrl,
          audience: 'https://MyDomain.auth0.com/api/v2/',
          responseType: 'token id_token',
          scope: 'openid'
        })

loginWithEmailPassword(email, password) {
return new Promise((resolve, reject) => {
  authInit.popup.loginWithCredentials({
    connection: 'Username-Password-Authentication',
    email: email,
    password: password,
    scope: 'openid'
  }, function(err, authResult) {
    if (err) reject(err)
    resolve(authResult)
  })
})
  }

And Enabled option ‘Allow Skipping User Consent’ in my Api Configuration, But this error still occur

code:"consent_required"
description:"Consent required"
error:"consent_required"
error_description:"Consent required"

#2

:wave: @nhatndm1193 is this happening just on localhost? Localhost will require consent always, even with the ‘Allow Skipping User Consent’ enabled.