How to force the user consent by default

Ready to post? :mag: First, try searching for your answer.
Hi all, i am working on google auth integration with my app. When the first time i sign up using google auth it gives me auth-error, and later login again works fine. i figured out the reason i am getting auth error is due to missing of the second user consent pop up (the one which asks the permission for scope).

Now my ask is how can we enforce always triggering of the two consent popup (google and my own)? Folr initial signup the pop up never get triggered and this result in the user dashboard, i can see the user has no assigned application. but when try to login again, because that consent appears and we approve it, then the user is binded and able to be logged in.

I am completely aware of the first party application and in local host you wont be able to skip the consent but plz kindly note that my requirement is always to show it.

(i have two integration one is github and one is google. the github always works fine but i am sure their settings are the same and they both connect to same api and application)

updates:
i tried to skip the firsty party app and in a non-localhost or 127 domain but also gets the auth error. when i test connection in the socal app for google, it says your connection works and this is what i expected given my second time log in does work. i am still not able to figure out why

Given both login and signup of auth0 use the same url, and i am not sure if there is sth wrong with auth0 initially detect this user does not exist and it should be a sign up process. again during initial signup i can see entry being added to user table but no authorized application. the application is binded only after second time login

Hey there @gabriel.gu ,

Please use the prompt=consent as a query param of the /authorize request to invoke the consent screen on each login event :slight_smile:

When redirecting to the /authorize endpoint, including the prompt=consent parameter will force users to provide consent, even if they have an existing user grant for the application and requested scopes.

Does this work for you?

thanks Marcelina, this works and also i find out the reason why i am consistently failing is due a an action where i am enforcing a check of role after adding one. it seems if i have a previous step for adding a role by assignRole function and then right after check the event.authorization.role, even though the role is properly assigned but the check will still fail. is this due to the lack of organization context?

Good morning / Good afternoon @gabriel.gu ,

Apologies for the delay.

All the Action functions are finalized after the full login event.

If, within the same flow, you update some user profile property and then want to check it, you will receive results true for the user from before the flow starts.