How to fix https://community.auth0.com/t/password-login-via-oidc-conformant-clients/10642

My application is deployed on google cloud, and login is complaining

access_denied : Password login via OIDC-conformant clients with externally-hosted login pages is unsupported. Alternatively, login could have been initiated from the wrong place (e.g., a bookmark).

I see teh answer - "Password login via OIDC-conformant clients..."

It takes me to the page

curl --request PATCH \
  --url 'https://YOUR_DOMAIN/api/v2/clients/YOUR_CLIENT_ID' \
  --header 'authorization: Bearer API2_ACCESS_TOKEN' \
  --header 'cache-control: no-cache' \
  --header 'content-type: application/json' \
  --data '{"initiate_login_uri": "<login_url>"}'

I can fill client id…what about login_url? and once I put values in these placeholders…what should I do?

MY auth_config.json is (which I used for testing from local machine)

“domain”: “v***.auth0.com”,

“clientId”: “Z***AQmdoS”,

“audience”: “http://localhost:8080”,

“apiUri”: “http://localhost:8080”,

“appUri”: “http://localhost:4200/callback

Please can I get a clear answer

Please anyone from Auth0 know this? I need steps - how to find appuri or login url, how to make it dynamic? and what to run and where. The url s are from Auth0 example, hence localhost

seems like this issue - auth stuck at the callback URL — not storing Auth0 token [SPA mode] · Issue #536 · nuxt-community/auth-module · GitHub

One possibility is that you are visiting the login URL directly, instead of initiating the login from the application.

You can also specify a route in your app as the Application Login URI and that route should redirect to Auth0’s /authorize URL with necessary parameters. You can use an Auth0 SDK to initiate this as well. For example, if you are using spa-js SDK, the auth0.loginWithRedirect() method would initiate the login.

If this doesn’t help, a HAR file will be helpful to see what’s going on.

1 Like

I think it is a little complex. My application is spring boot with angular inside. loginWithRedirect is already used. Question is what needs to used instead of localhost for a production version

I’m afraid the question is not quite clear then. What I mentioned were the solutions for the error message you had come across. Are you able to share a HAR, if that’s not the case?

what needs to used instead of localhost for a production version

You would usually use the production app’s URL in that case, but since that should be obvious, I’m guessing there’s more to your question - so it’d be help to understand the question a bit more.

1 Like

Why do you think the question is not clear?
I have used the example provided by auth0, but that example uses localhost

But the scenario is “production” It is a real domain name. If a real www.example.com has to use Auth0, then what should be the property values?
My other question has the links of example I used
How to get all user Claims with tokenOptions

Look at this

The Complete Guide to Angular User Authentication with Auth01k8jr9drollup_gaMTEyNzMzMzgxOC4xNjA0NjE0MjQwrollup_ga_F1G3E656YZ*MTYyNjYyMjI0My4zMy4xLjE2MjY2MjI1NzYuNjA.

:hammer_and_wrench: Allowed Callback URL

:hammer_and_wrench: Allowed Logout URL

section

I made some progress, but stuck on callback page. Looks like it got the session, but its not coming to home page? . How can I solve it?
The issue seems similar to auth stuck at the callback URL — not storing Auth0 token [SPA mode] · Issue #536 · nuxt-community/auth-module · GitHub

I have this in my package json

@auth0/auth0-angular”: “^1.3.1”,

"@auth0/auth0-spa-js": "^1.13.5",


"auth0-js": "^9.14.0",

Are all these required?

Hey @k-auth0,

If a real www.example.com has to use Auth0, then what should be the property values?

The short answer is that you will need to replace all your localhost URLs with the production URL.

Can you please share a HAR file that captures callback issue? You can DM it as well.

1 Like

Hi Thameera,
Im sure it is a know issue - where I get the Auth0 login dialog, complete it, I get to see /callback/…
and it stays there

I will have to check about HAR file. Never supplied anyone before
It is possible to give me pointers on why stuck at callback url…and not going to home page, without HAR?

Thanks for responses from @thameera

I m still stuck on callback url…and not sure what is happening? I have seen some links that are discussing this type of issue but no idea on the fix.

Can you please help, as the application is not working

Please can someone help here? My architecture team wants to pursue alternate options, if we cant resolve this problem. we already sacrificed websockets

Ok It looks difficult as my app is a spring boot with integrated angular. When I tested locally from the last siz months…it was as 2 different apps. But for deployment, I combined into single archive. If Auth0 was not tried in this type of scenario, then we will leave it here, as it is not working for my app

Sad that I have moved on to google directly. Wish I had support from Auth0.