How do I log in on my http://localhost system?

So how do folks test logging in, when running a localhost deployment, which doesn’t have an httpS url?

Application configuration does not let me enter an http (as opposed to httpS) URL (e. g. http://localhost:4000) as my Application Login URI, and this thread seems to confirm that http is not an option:

The “Test application locally” documentation page (Test Applications Locally) does not address address this question.

In my test, I used an ngrok session (it exposed an external https endpoint, which terminated an https connections and routes the connection to my localhost’s http://localhost:4000), but that is an unreasonably heavy burden to impose on the team, when folks are just working on their features locally, and just want to log into the system running on their machines.

Is there a reasonably lightweight approach for logging into a system that is running on my localhost, over http?

Thank you!

Hello @markmark_kel!

The application login uri is not required and can be skipped for testing purposes, or altogether. None of our sample applications rely on an application login uri and allow for login via http://localhost:XXX - Our react sample utilizes http://localhost:3000 for example:

1 Like

The application login uri is not required and can be skipped for testing purposes, or altogether.

Ok, thank you, leaving the “Application Login URI” field empty, at least for the Auth0 application that serves our localhost deployments seems to work.

Omitting the value does seem to go against the description next to the field in Auth0 Application Settings UI, which states that “In some scenarios, Auth0 will need to redirect to your application’s login page. This URI needs to point to a route in your application that should redirect to your tenant’s /authorize endpoint.” So we’ll see if we run into actual problems. We will probably still plan to populate the value in the auth0 applications serving our staging and production environments (which has its own problems, because doing this introduces and inconsistency between our locahost).

In any case, thank you!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.