Auth0 Home Blog Docs

How can I set email_verified with custom database?



I’m calling update user via patch call to domain/users/{userid} and setting ‘email_verified’=>true, when I check in auth0 dashboard it says the user is verified which is what I would expect, however in the custom database I’m using it’s still false. Subsequent login attempts to that user id then fail because the user isn’t verified. If I update the DB via sql directly, subsequent logins work. Is there a call, rule or custom script I can run that will handle updating the db as well?


Updating users via the Management API v2 only updates the Auth0 user profile; it does not update the user profile in the custom database. If you are not importing users to Auth0, you should update the user directly in your custom database, in which case the Auth0 user profile will be updated on the next login.

To make sure the Auth0 user profile is updated with the email_verified status, make sure you are returning that as part of the user profile returned by the Login script, e.g.

callback(null,   {
      email_verified: user.email_verified


This did the trick for me. Thanks !


I am using the Auth0 wordpress plugin and connecting to a custom database. I have the plugin set to not require verified email for login. I have also updated the login callback to always set email_verfied = true. However, the Auth0 user record continues to show pending. When a user tries to login on wordpress, they are getting the “sorry that email already exists” message. Manually setting their email as verified in Auth0 allows them to successfully log in. What am I missing?