Hosted Pages: Login and SignUp tab missing

I have three separate tenants and believe they are all configured the same way - using hosted login and signup ( this.auth0.authorize(); )
However the staging tenant logon screen is missing the tabs of Login and Signup…
any clue as to why?
Thanks

I see a lot of differences between the two screens. One has Google, Linkedin and Email while the other only has Google and Email. This last one has the “Don’t remember your password” while the first one does not. And then there is the missing tabs (it means that one only has login and the other has both login and signup). I would encourage you to check the Hosted Login Page on your tenants and make sure the Lock configuration is the same for all. Regarding those specific issues, you can see the allowSignUp, allowedConnections and allowForgotPassword
configuration options. For the available connections shown, you can also check which ones are enabled for your client in the dashboard.

You can read more about Lock configuration here: https://auth0.com/docs/libraries/lock/v11/configuration

@ricardo.batista appreciate all your info but…

TEST #1 :

  1. I go to custom pages and grab the URL for PREVIEW of login
  2. I turn OFF custom login
  3. Paste the URL from step 1 into a new tab
  4. The results are standard login, but missing the Sign Up tab

Shouldn’t this be using all defaults which should show SignUp? It does on my other two tenants

TEST #2 :

  1. From my Angular app I call the following: **

this.auth0.authorize({allowSignUp:
true});

Same outcome - no signup

**

PS I realize I had LinkedIn turned on but is not the heart of my issue

@ricardo.batista appreciate all your info but…

TEST #1 :

  1. I go to custom pages and grab the URL for PREVIEW of login
  2. I turn OFF custom login
  3. Paste the URL from step 1 into a new tab
  4. The results are standard login, but missing the Sign Up tab

Shouldn’t this be using all defaults which should show SignUp? It does on my other two tenants

TEST #2 :

  1. From my Angular app I call the following: **

this.auth0.authorize({allowSignUp:
true});

Same outcome - no signup

**

PS I realize I had LinkedIn turned on but is not the heart of my issue

Yes, it should be using all defaults if you have the hosted login page turned off. Can you try the preview URL in an chrome incognito? (just to prevent any caching issues)

https://{YOUR_AUTH0_DOMAIN}/login?client={YOUR_CLIENT_ID}

Just did with same result… thanks for suggestion

Also I just realized my TEST 2 is not valid - I was sending Lock configurations into Autho.js – but TEST 1 is still valid

Thanks for suggestion I did that with same results.

Hey there!

Sorry for such huge delay in response! We’re doing our best in providing you with best developer support experience out there, but sometimes our bandwidth is not enough comparing to the number of incoming questions.

Wanted to reach out to know if you still require further assistance?