Last Updated: Sep 19, 2024
Overview
When creating an Okta Workforce Enterprise connection, Home Realm Discovery (HRD) does not work when using the Classic Universal Login experience with Lock. All other Enterprise connections work fine, but the domains configured for the Okta Workforce connection do not trigger HRD.
When entering an email address ending in a domain that is configured for HRD in the Okta Workforce connection, the password input does not go away, it keeps asking for a password.
Applies To
- Classic Universal Login
- Lock
- Home Realm Discovery (HRD)
- Okta Workforce Enterprise connection
Cause
The Okta Workforce Connection type is a relatively new feature in Auth0 and is only supported in Lock.js v11.34 or greater, as it shows in the corresponding release note.
Solution
Navigate to the branding page in the Auth0 Dashboard and update the current Lock version to the latest available version:
<script src="https://cdn.auth0.com/js/lock/11.x.y/lock.min.js"></script>;
The latest updates can be found here.
Please remember that once the customization toggle is flipped on for a given Universal Login page, Auth0 can no longer automatically update it. It is the responsibility of the Auth0 Tenant Admin to update and maintain the page going forward. This includes updating the version numbers for any included Auth0 SDK or widget.