Auth0 Home Blog Docs

Heroku deployment localhost error

I’m creating an application in nodejs, and using heroku to deploy. I got Auth0 working great locally, but when I deployed to heroku it doesn’t work. Each time I click ‘login’ I get

This site can’t be reached
localhost refused to connect.
Search Google for [localhost 3000 callback]

The allowed callback URLs I have listed are http://localhost:3000/callback, http://localhost:3000, and [mydomain].com/callback.

Anyone have an idea how to troubleshoot this?

Hi there @elizabethwarners, we’d be happy to help. Judging by your listed Allowed callback URLs you may not have all of the new fully qualified production routes set for your application to flow through in your settings. We actually have a great section on Heroku in the below blog post, I recommend giving it a peek. Please let me know if this helps you in your quest or if you have any questions!

Hey James, thanks for the help! Turns out I had never enabled the Auth0 add-on in heroku.

I have a follow up question now: With the add-on, I’m not getting any errors. However, the login box pops up with ‘Default App’ as the title. Shouldn’t that be my application’s name?

After I click login or even ‘sign in with google’, the page just reloads and I’m back to the login pop up.

Any ideas where I’m going wrong?

Following up @elizabethwarners, the ‘Default App’ is likely declared somewhere in your settings. Can you share a code snippet of your auth flow as it sounds like something with your redirect may be a little off? Thanks in advance!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.