Google login not working for JP-1 tenants

We have several test Auth0 tenants, some are on the US-1 server, and two are on the JP-1 server.

All of them have Google Login enabled as well as username + password.
On the two JP-1 tenants, Google Login stopped working with no changes on our side:

Looks like something went wrong!
There could be a misconfiguration in the system or a service outage. We track these errors automatically, but if the problem persists feel free to contact us with this tracking id: fbfe7b13a2e55fb7eabd.

The tenants that are on US-1 are not affected.
Normal username + password login works without issues on all tenants.

I checked but there is nothing to indicate any type of issue.

Any ideas would be appreciated.

1 Like

Hi @perjg,

Welcome to the Auth0 Community!

I understand you have encountered issues with the Google social connection login with your JP-1 tenants.

After testing this myself, I could not reproduce the issue you observed. Instead, I could successfully log in using the Google Social Connection on both JP-1 and US-1 tenants.

Given that, could you please capture the failed login event in a HAR file and send it to me to investigate further?


I have the same problem. Please, helpme.

tracking id: 92ca5d11ed7f61434336 (6.7 MB)

1 Like

Hi Rueben,

I work with Per and our customers are affected by this issue. So thanks for testing it yourself.

But is testing it once on your side really the only thing you did? That sounds like you are not really aware of how big of an impact the issue is. And marking your answer as solution is very premature and not appropriate at all, because nothing is solved for us here yet. The issue still persists.

Did you at least check the logs (server side) for the trackingid we provided to see if there were any login issues for tenants in JP-1 in the last 24-48 hours? That is the very minimum of what I expect you to do, yet from what you wrote it is not apparent to me whether you actually did check the logs.

Plus you have not only Per and me reporting this, but also yerkobits reported it about 3 hours ago as well (and provided a .har file for your convenience), so please check again and this time also check the logs.

– Daniel

1 Like

I am currently having the same problem on JP-1 server.
At least until 5pm the day before yesterday, I was able to log in with my Google account normally. (4.0 MB)

Here is the har file. (420.6 KB)

And here is one more from another tenant on JP-1 where we have the exact same issue.

I used the same tab in the incognito window and used the same Google Account

I am also facing the same problem as the others with JP-1. Nothing as been changed in our code base… Two days ago, the login with google has stopped working. Any information would be appreciated.

we have had the same issue since 2 June, but the Auth0 health status doesn’t indicate if the problem is related to the infra upgrade. I tried to check login logs but the monitor doesn’t have any record, looks like it was blocked from a very early stage. does anyone know how should I debug this? thanks a lot.

1 Like

Any updates on this thread ? I’m experienced same issue

Are you using Auth0’s dev key for Google OAuth(you don’t apply your own Google API key for OAuth)? I might found the root cause - it seems like, after the infra upgrade, Auth0’s dev key does not work anymore. In my case, because my prod env has applied my own key and it works, so I just apply my key to all tenets and now Google OAuath works fine.

1 Like

thanks for your help. I will try to change to prod key

Hi @perjg, @yerkobits, @danielkg, @taiyaki715, @veillj1, @iamcxa and @lamlv

Thank you for all the responses, and I apologize for the delayed reply.

After looking deeper into this, I can confirm that the origin of the issue comes from using the Google Social Connection with the Auth0 Developer Keys.

As a friendly reminder, the Auth0 Development keys are intended for testing purposes only. For Production Environments, we recommend using your own Google development keys.

Please follow our setup guide described in this documentation:

To add on, there is also a warning in your Google Social Connection setting and the Auth0 Logs to inform you about this:

You are using Auth0 development keys which are only intended for use in development and testing. This connection (google-oauth2) should be configured with your own Development Keys to enable the consent page to show your logo instead of Auth0’s. AUTH0 DEVELOPMENT KEYS SHOULD NOT BE USED ON PRODUCTION ENVIRONMENTS. To learn more about Development Keys please refer to Test Social Connections with Auth0 Developer Keys.

Please let me know how this goes after making these changes.


1 Like

I’ve changed all the affected tenants to use our own keys and I can confirm that Google Login now works as before. Thanks for your help.


I understand about this but do ur guys have any plan or timeline to fix development key issues ?

Hi @perjg,

I am glad that everything is working now!

1 Like

Hi @lamlv,

Unfortunately, there are no plans to “fix” the development keys to address the intermittent issues you have experienced. As mentioned in our documentation here, this is a strict limitation.

To ensure proper functionality with Social Connections, we strongly recommend using your own Developer Keys.

I hope this clarifies your concerns. If you have any further questions, please let me know.

Thank you,

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.