Github deployments extenstion doesn't recieve code updates

Hi All

I’m using Auth0 for a while and till now everything was very simple and clear and worked great.
Lately I asked to implement the Github deployment extension in one of our tenant.
I follow the instructions that writing here:

  1. Configure the extension in our Auth0 tenant.
  2. Create a new Github repository especially for this use case.
  3. Integrate between 1 and 2 with Webhooks.
  4. Worked with auth0-cli-tool to receive the tenant directory structure.

When I try to update email templates or rules via the github repository I getting into a problem.
The webhook from github repository tells that a push was made and an event send to auth0 API.
The auth0 API response with 202 HTTP Accepted but in the body I see this message:
{“message”:“Request ignored, none of the Rules or Database Connection scripts were changed.”}
Even though that I do change the rules as described in the instructions (see link above).
Auth0 rules is not updated and the deployments tab under the github deployment extension doesn’t recognize my last git push command.

What do I missing here?

Best regards,

I found the issue, The reference to the directory path was wrong.

1 Like

Perfect! Glad you have it working now!

1 Like