Full Stack Java with React, Spring Boot, and JHipster

This tutorial shows you how to create a slick-looking, full-stack, secure application using React, Spring Boot, and JHipster.
Read more…

:writing_hand:t2: Brought to you by Matt Raible

Hi Folks! We’re happy to help if you have any questions!

Hi, I’ve followed all the steps, replaced everything in the .auth0.env file, but when I login, I’m not redirected to auth0, it’s still using keycloak… any ideas?

I fixed it. Since I’m on windows, env variables did not set properly

1 Like

Perfect! Glad to hear that!

This topic was automatically closed after 23 days. New replies are no longer allowed.

Hi there,
Great post, I’m new to jhipster, this one seemed like a good one to get started.
I installed WSL and recommended artifacts to get it running.
But quickly ran into a couple of problems, browsed for fixes but was unable to find one.

  1. JHipster multi-scrollable options not working in my terminal.
    I’m using Windows Terminal, scrollable options of creating the JHipster app do not display properly.
    I was unable to select the “Bootswatch theme” and the “Additional languages”, the JHipster text based interface misbehaves when scrolling down the options.
    Is there a terminal setting that needs to be set?
    I tried using a couple of TERM options to no avail (vt100, ansi), seems there are no CLI options to script JHipster out of this.
  2. Enabling auth0 throws URISyntaxException.
    I followed the process to convert to auth0 authentication, but I kept getting a URI
    java.net.URISyntaxException: Illegal character in path at index for SPRING_SECURITY_OAUTH2_CLIENT_PROVIDER_OIDC_ISSUER_URI=https://dev–h28b30v.us.auth0.com
    and the app wouldn’t run.
    I was able to get it running, but wanted the tutorial to go smooth :slight_smile:
    Any help is appreciated.

Your Auth0 issuer needs to end with a /. It also looks like your dash isn’t a normal dash. Can you try changing your issuer to https://dev-h28b30v.us.auth0.com/?

1 Like

Thanks for helping on this one Matt!