Auth0 Home Blog Docs

First Party - Skip consent screen

Hi,

I am using Auth0 in my web app and enabled skipping of consent screen for first party. However when user signs up and login it is still asking for consent. How can I skip the consent screen.

Hey there @tbansal!

I did some research and I found those articles that might be helpful:

Let me know if you have more questions!

I already checked that document. But my application is not skipping it.

As of now I need you to provide me with more context as you said you’ve followed the tutorial and it didn’t work for you then I need more details. Can you share what building blocks you use to build your app? Steps you take etc. Which version of Auth0.js you use?

Hey there!

Have you had a chance to see my last message?

Hey Konrad,

Yes sure. We are using angular 6 and following package from npm -
auth0-lock - 11.12.1
Auth0.js - 9.9.0

I have Allow Skip consent enabled on my Application.
My site is hosted on https also.

Is there any other need for it in lock configuration etc to avoid it. I do not have localhost anywhere in allowed callbacks etc.

Let me try to reproduce it and discuss it internally what might be the potential reason. I’ll get back to you as soon as I have any info to relay!

I have Allow Skip consent enabled on my Application.

Just to confirm, you are setting this in the API settings under Dashboard > APIs, not under Dashboard > Applications, right?

Also, in your authorization request in your client application, you are providing the API identifier of this API as the audience, correct? Because otherwise, if this audience is missing, it will also not work.