"Failed to obtain access token" and Error "AADSTS50146" with Azure AD (Entra ID) Connection

Last Updated: Feb 13, 2025

Overview

A customer is experiencing an issue attempting to authenticate with an Azure AD (Entra ID) connection via Auth0.
The authentication flow fails with the following error message:

“error”: { “message”: “failed to obtain access token”, “oauthError”: “invalid_request”, “payload”: “{"error":"invalid_request","error_description":"AADSTS50146: This application is required to be configured with an application-specific signing key. It is either not configured with one, or the key has expired or is not yet valid.”, “type”: “request-error” }

Cause

This is caused by a misconfiguration of the application on the Azure AD (Entra ID) side. The error could also be due to a misconfigured Client Secret.

Solution

The Auth0 Troubleshooting docs for Azure AD (Entra ID) provide additional details for a misconfigured Client Secret.

For issues with Azure AD (Entra ID) configuration, contact Microsoft support.