Last Updated: Sep 12, 2024
Overview
This article explains the reason behind the following for an Azure AD connection login:
{
"type": "f",
"description": "failed to obtain access token",
"connection_id": "",
"details": {
"error": {
"message": "failed to obtain access token",
"oauthError": "invalid_request",
"type": "request-error",
"payload": "{\"error\":\"invalid_request\",\"error_description\":\"AADSTS900432: Confidential Client is not supported in Cross Cloud request."}"
},
}
Applies To
- Azure AD
- Failed Login
Cause
The client secret on the Azure end expired.
Solution
Generate a new client secret in Azure and save it in the connection at Auth0 per the instructions for Creating a client secret.