Error when sorting users

I’m using the V2 of the auth0 API (free). With the same query to list users sometimes I get a 400 error and sometimes it works correctly

For example with the query :
Sometimes report 400 error:

Sometimes works well:


I am getting the same error when sorting on “username”.
Using search engine = v3.

Would be great to get some feedback from devs on this one :slight_smile:

Yes I got the same, but only on some tenants

GET /api/v2/users?sort=updated_at:-1 worked for ages, and now sorting by updated_at returns the same error as in the first post here.

I have detected this morning, that sorting by updated_at:-1 works again in our tenant. Something at auth0 has changed overnight.

I am in contact with auth0 support to figure out what updates have been done…


Thanks for letting us know @jbauerrfid! Once you figure it out with our support please share it here in the community for the benefit of others! Thank you!

Feedback from auth0 support (all names removed to respect privacy):

I checked internally for the time you faced the issue on your tenant

we had a regression in usersearch API in some environment (AU, EU) and a very small percentage of tenants
on May 12th caused by api2 split rollout.

The fix has already been identified and deployed.

Retested from our side and so we don’t see issues.


Thanks a lot for sharing that with the rest of community!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.