EPROTO SSL routines

Our team is currently migrating from rules to actions.
In one of our actions we used request(…) to perform an HTTP calls towards AWS. In actions we want to implement axios.

we use aws4 to sign our AWS request, after it’s signed we use axios to perform the request. (as below)

  aws4.sign(options, credentials);
  const res = await axios(options);

But when we test it, it gives the following error:

{
  "code": "EPROTO",
  "message": "write EPROTO 125084274096000:error:1408F10B:SSL routines:ssl3_get_record:wrong version number:../deps/openssl/openssl/ssl/record/ssl3_record.c:332:\n",
  "name": "Error"
}

I saw it might be related to a proxy, but how to configure this to get it working?

Thanks.

Hi @ivo.h

Welcome to the Auth0 community !!!

It seems to be an error related to incompatibility between Axios and OpenSSL library we are using. Would you mind to try using an older version of Axios instead of the latest version?

Thank you
Jeff

1 Like

I’ve tried to use older versios of axios (to 0.20.0-0 1 year ago), after that did not succeed. I also tried some node-fetch versions.
Same error.

But for now, I think we can just stick to rules.