Entire site 404's once published because of too long of an url

Hello, i am very new to auth0 and all kinds of things like this so i am sorry if i am not very clear.

I’ve developed a website in .net 4.7.2 and everything worked fine running off of my local IIS Express but once i published it to my UAT, (which is a internal facing site at the moment with no connection outside) to have it reviewed, it started to 404 on every single page i try to navigate onto.
This includes pages that i have not put the [Authorize] attribute on.

When navigating to a page it creates a very long URL and which causes the page to 404.

I thought this may of been a problem i have caused so i tried uploading the example offered on auth0 and the same thing occurred.

Something else that has happened is that at times i would be able to use the website fine but once i close my browser and open the site again it would return to 404ing, but i havent been able to do this again.

Below are screenshots of the error page, my auth0 application settings, and the web.config for my project

I am not a .Net expert. But this doesn’t look like Auth0 to me, this looks like something in your app. Look at your first screenshot. The returnUrl looks completely wrong. Check out how that gets generated and that should give you a clue.


Yes, sorry I’ve realised that and forgotten to close this post

No worries it will auto-close 15 days after being marked as solved!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.