Empty User from a SAML Connection

Overview

This article explains a potential cause and solution for users who come in empty from a SAML connection.

Applies To

  • Enterprise connections
  • SAML
  • Users

Cause

The Identity Provider (IdP) is not sending attributes to Auth0.

Solution

Check the IdP configuration and ensure that at least First Name, Last Name, and email are included. Also, ensure the mappings are correct in Auth0.

  • It is also possible to check the SAML response to see which attributes the IdP sends.