Email verification exception upon creating new user

My issue is the exact same as described here: Unable to create user with verified email [ POST - /api/v2/users ]

But since Auth0 aggressively closes issues, it’s really cumbersome to keep context throughout different issues (I’ll most definitely file a separate topic for this, as it’s really irritating and inconvenient…)

So:

I’m trying to create new user with management API, but I have some troubles.
It create my user, but user’s email is not verified even if I set email_verified : true & verify_email : false in request body.

Why email_verified field is overwritten to false ?

Best,
ajv

I’ve retested it and I see that the verify_email option is respected - the verification e-mail is not sent out. But the email_verified field is not respected and defaults to false.

Coming back to this, as the verify_email option is yet again not respected - an e-mail is sent out.

I’m not sure why but the behaviour is very unstable - as the flag was not working 19 days ago, then worked 18 days ago and now is not working again (and email_verified hasn’t worked the entire time neither).

Our use case is that we’re trying to provide “reset password” functionality for magic link users by creating a temporary password for them first (via a signup through /dbconnections/signup) and we don’t want them to receive the signup e-mail. And since they have an existing magic link authorization, we’d also want the email_verified option to be respected during signup. Or should that be patched later?

1 Like

I am having the same problem. I want to create an unverified user against the email connection, but I don’t want to send any e-mail.
I tried email_verified: false and verify_email: false but the email is still sent.