Auth0 Home Blog Docs

Does domain require https


#1

Should the “domain” for my account have https:// in front of it?

Currently, under application settings, I see my domain as companyname.auth0.com which doesn’t have https:// in the beginning or a / at the end. Is this a problem?

I’m trying to get my ASP.NET Core 2.1 app with React front end to use Auth0 but keep getting 401 unauthorized. As I went through examples, I got the feeling that my domain should be https://companyname.auth0.com OR https://companyname.auth0.com/.

Do I need to update my domain and if so, where would I do it?

Thanks,
Sam


#2

I responded in your StackOverflow post, but putting it here as well. Yes, you should include the https:// as well as the full callback as appropriate


#3

Thank you but you didn’t give me an answer for the second part. How do I update it? Do I need to delete my Auth0 account and re-create it? My research is showing me that I can’t update the domain for the account.

To be 100% clear, I am NOT asking whether there should be https:// in front of the domain in the code in my app. I’m asking whether the domain should have https:// here on Auth0 settings i.e. dashboard/account.


#4

Oh my apologies… the domain on the dashboard doesn’t need that and should work fine the way that it is. Let me see if I can find some assistance on this for you.


#5

I’d really really appreciate some push on this as I’ve been stuck for a while.

I was thinking if I needed to change the audience to http://localhost:49065/api as I work on the app on my dev machine but if I’m understanding it correctly, the audience is just an identifier and Auth0 does not really make a call so I should be able to leave it as I registered it in API settings through the dashboard.


#6

Hey @imsam67 can we get a example of the HTTP request that you are making and how you’re initializing your authorization request. When you get a chance can you DM me your tenant name? Also do you see any errors in your Auth0 tenant logs? Thanks in advance!


#7

I wanted to follow up with you @imsam67 that I have responded to your direct message with a series of steps to try. Please let me know if you have any additional questions!