Auth0 Home Blog Docs

Disable Sign Up through Auth0 ONLY -> I want to use my own sign up method

api
#1

I want to remove the “Sign Up” tab on the Auth0 login page, but I want to have a registration form on my site that allows for sign ups. When I go in and disable sign ups, I cannot create users from my own api. I want to ONLY be able to sign up users from my api.

Also, why can I not sign up users with “email_verified”: true??? They have to verify their email through my site before I ever sign them up with Auth0.

Thanks!

#2

Hello @diaewad,

You should be able to build your own signup solution using Lock or the Auth0 APIs, and you can manually set "email_verified": "true" when you create a new account.

#3

When I initially create the user, I send “email_verified: true” but Auth0 still sets it to false. Do I have to do a second call to update the user? Because that’s really frustrating.

Also, I have built my sign-up solution. What I’m asking is how to remove the “Sign Up” tab on the Auth0 login but still allow sign ups via my solution.

#4

You shouldn’t have to make a second call to set email_verified to true. What is your process for setting that attribute?

You can disable the sign up tab.

#5

When creating a new user, I send this:

{
    "client_id": process.env.client_id,
    "email": email,
    "username": username,
    "password": password,
    "connection": process.env.connectionName,
    "user_metadata": {
        "first_name": firstName,
        "last_name": lastName
    },
    "email_verified": true
}

Everything works except the email_verified portion. No matter what, it will always create the new user with email_verified: false.

#6

I’m honestly not sure why it is not working. I created a user just now using the following:

[
    {
        "username": "markdtest1416",
        "email": "me+test1416@foo.com",
        "email_verified": true,
        "password": "A Very Secure Password",
        "given_name": "Mark",
        "family_name": "Drummond",
        "connection": "my-db"
    }
]

And email_verified is set to true as expected:

  {
    .
    .
    .
    "email_verified": true,
    .
    .
    .
}

Now, I did this by calling the Management API from a python script using the Auth0 python SDK. There must be something different in the way you are creating the user. Can you provide more details?

#7

Sorry for the late reply! I must have missed the email letting me know you responded.

I’m using Node to reach out to a M2M api to create a user. When I tried to go through Management API it said I wasn’t authorized, so maybe that’s the issue.