Auth0 Home Blog Docs

Custom domains with Social Connections

auth0

#1

I’m trying to use a custom domain with Social Connections. I have a paid plan (Developer) and have set up and verified my custom domain and it is in the ready state. I have updated the OAuth applications under the social connections to accept both the custom domain and auth0 domain callback URLs.

Let’s say my auth0 domain is blub-auth0-com and my custom domain is auth-blub-org (using - instead of . because of link limit). My app works fine when I set the Auth0 domain to blub-auth0-com. When I switch it to use auth-blub-org, I get the “you should not be hitting this endpoint” popup https://auth0.com/docs/custom-domains#-you-should-not-be-hitting-this-endpoint- and Auth0 is unable to load any of the social connectors. The troubleshooting guide suggests https://auth0.com/docs/custom-domains/additional-configuration#configure-social-identity-providers which for social connections suggests

If you want to use social identity providers with your custom domain, you must update the Allowed Callback URLs to include your custom domain.

Which doesn’t make much sense since it is not my app’s URLs that have changed, it’s Auth0s. Also, adding the custom domain callback URLs to the comma-delimited list does not help.

The domain for the app cannot be changed, its setting box is grayed out. This last three comments on topic Unable to authorized with the custom domain reflect my my current status, I have a “ready” custom domain that I can’t seem to use. Note that those comments aren’t really related to the initial issue nor its resolution.


Unable to authorized with the custom domain
#2

Hi @ddatomist

Are you seeing an error in your Auth0 logs? Those should provide some more insight.

Also, are you using Universal Login or Embedded Lock? Depending on which of those you are using will determine what extra configuration is need. Here’s a link to the extra config


#3

Adding the code for the Universal Login to the Hosted Pages > Login code did the trick. Thanks.


#4

Sorry @ddatomist that we weren’t able to reach out earlier and thanks a lot for sharing the solution with the community!