Custom domain with new universal login

Hi :slightly_smiling_face:
I am using the new universal login and I have added my custom domain. But my login page still shows the auth0 subdomain instead of my custom domain that I added.
Any idea what I am doing wrong?

Hi @wahiduzzamankhan007

After adding and verifying your custom domain in the dashboard, it just means that it is ready to be used. You’ll then need to change how your application connects to Auth0. Taking Auth0.js as an example, to change from the Auth0 domain to your custom domain, you’d need to put your custom domain in the domain parameter for the auth0.WebAuth object:

<script type="text/javascript">
  var webAuth = new auth0.WebAuth({
    domain:       'YOUR_CUSTOM_DOMAIN',
    clientID:     'YOUR_CLIENT_ID'

You can read more about how the custom domain works and how it is configured here:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.