Create Okta Enterprise connection using auth0 API

I am trying to create OKTA enterprise connection using Auth0 management API, below is the my payload.
“name”: “connectionfromapi”,
“displayName”: “connectionfromapi”,
“options”: {
“use_wsfed”: false,
“useCommonEndpoint”: false,
“basic_profile”: false,
“ext_profile”: false,
“ext_groups”: false,
“ext_nested_groups”: false,
“api_enable_users”: false,
“should_trust_email_verified_connection”: “never_set_emails_as_verified”,
“okta_domain”: “”,
“client_id”: “clientID”,
“client_secret”: “secret”
“enabledClients”: ,
“strategy”: “okta”
}, but i am getting error like Auth0.Core.Exceptions.ErrorApiException: "Okta Domain" is required.

  1. Can Someone suggest me what is wrong in my payload?

  2. and how to include realms while creating okta connection?
    while i am able to add realms in dashboard, but getting error like “Realms is only supported for database connections.” while using api.

You named “okta_domain” the parameter that should be put as “domain”. Try this, I am pretty confident it will solve your first problem.

@julien.nanquette Worked Thanks

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.