Couldn't send email verification for user

i couldn’t send email verification from rest api

API: https://####.us.auth0.com/api/v2/jobs/verification-email
RESPONSE: {
“statusCode”: 400,
“error”: “Bad Request”,
“message”: “The identity field is not currently enabled for this tenant”,
“errorCode”: “operation_not_supported”
}
but, it is working on UI part.

Hi @ashok.k,

Could you please send an example request body so that I can look into this further? You can use fake data for the property values to keep that info concealed.

Thanks!

Stephanie

hi @stephanie.chamblee

I also have this problem when i include the identity json, here’s mine:
{
“user_id”: “auth0|5ff4d819e00a83006e89eedb”,
“identity”: {
“user_id”: “5ff4d819e00a83006e89eedb”,
“provider”: “auth0”
}
}

I tried all users i created on “users & roles” dashboard, but nothing works,
this also occurs on /api/v2/tickets/email-verification

and may i know what’s the difference between job/email-verification vs tickets/email-verification

Hi @stephanie.chamblee,

This is the URL and request body for the verification email

https://dev-wfdztj0c.us.auth0.com/api/v2/jobs/verification-email
{

“user_id”: “auth0|5fe43c5354ea200069c7b0c6”,

“client_id”: “m7XYIwOIrIilH21CHqXK7g35ZgtPuiUE”,

“identity”: {

"user_id": "5fe43c5354ea200069c7b0c6",

"provider": "auth0"

}

}

It looks like since it is a database connection, you don’t need to send the identity parameter. If you just send the user_id and optionally the application client_id, the job will be created.

{
  "user_id": "auth0|5fe43c5354ea200069c7b0c6",
  "client_id": "m7XYIwOIrIilH21CHqXK7g35ZgtPuiUE"
}
1 Like