Cors - we're sorry, something went wrong when attempting to log in

I have configured the database connection, everything was working fine, until one day it started throwing errors when people attempt to signup

and when I check the console, I see the following error

Access to XMLHttpRequest at ‘’ from origin ‘’ has been blocked by CORS policy: Response to preflight request doesn’t pass access control check: No ‘Access-Control-Allow-Origin’ header is present on the requested resource.

Now I have added the website to
Allowed Origins (CORS) section

it still has errors

need help

Hey there @mak2!

Firstly could you let me know if you’ve changed something in the meantime between ot was working and it started throwing such error?

Nothing changed from my end, but getting this CORS error.
Not sure if anything setting has changed, but now I have gone and added the domain in the CORS section as well, still no effect

1 Like

Thanks for expanding on that! I’ll dig into it and let you know once I find something!

Thank you, do let know if you any info from my end

Sure I need to reproduce it and discuss internally! Will get back to you as soon as I have news to share!

How is that i can get a support on this, this issue is stopping me from release,
not able to use database registration for users

Hey there!

Sorry I haven’t assigned myself to this and it completely got away from my attention.

Can you let me know more context around it what database you use, what are potential steps you think I need to make to reproduce it, anything that can be helpful for me debugging it?

Thank you!

I am using Auth0 database connection, there is no Custom database.
it used to work, but now a days its not working, it throws the above error, I can send you the link as well where you can see by yourself

let know what info you need

Ok i think I’ve got everything for now let me try to dive into it and get back to you with the news!

Hey again!

I’ve started discussing it internally and can you provide us with HTTP trace containing all the requests since accessing the application to the problem?

Thank you!

This is waht I see in logs
“date”: “2019-03-22T11:26:03.497Z”,
“type”: “fco”,
“description”: “Origin is not allowed. Behavior used for check: WEB ORIGINS”,
“connection_id”: “”,
“ip”: “”,
“user_agent”: “Chrome 72.0.3626 / Mac OS X 10.14.0”,
“details”: {
“xhr”: false,
“method”: “OPTIONS”,
“origin”: “”,
“headers”: {
“x-forwarded-proto”: “https”,
“x-forwarded-for”: “,”,
“host”: “”,
“x-forwarded-port”: “443”,
“x-amzn-trace-id”: “Root=1-5c94c64b-57583ec2fe238a56e89cbd91”,
“pragma”: “no-cache”,
“cache-control”: “no-cache”,
“access-control-request-method”: “POST”,
“origin”: “”,
“user-agent”: “Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/72.0.3626.121 Safari/537.36”,
“access-control-request-headers”: “auth0-client,content-type”,
“accept”: “/”,
“referer”: “”,
“accept-encoding”: “gzip, deflate, br”,
“accept-language”: “en-US,en;q=0.9”
“host”: “”,
“originalUrl”: “/dbconnections/signup”
“hostname”: “”,
“log_id”: “90020190322112603497469719864495929658769977486291005197”,
“isMobile”: false

Thanks @mak2! Let me investigate this and get back to you soon!

hi Any updates on this?

Hey there @mak2!

That log does not seem to have nothing to do with /usernamepassword/login which is the endpoint mentioned in the initial message

That log should be resolved by ensuring proper client configuration.


I am confused on what needs to be done, let know what needs ot be done, as we have not changed anything from out end

I love your product, and would like to stick to it, but if there is no way for me debug the Issue we are gated on going production for it


We tried with Auth0Provider angularjs 9.11 Auth0 library and everything seems working fine include the UserName-password database connection, that proves that there is nothing wrong in configuration on our end, would like to request your help on the same

We are more than happy to use Auth0Provider as well, but it has limited configuration capabilities.
for e.g we are not able to set the logo

1 Like