"config.json file is missing"

Hello all!

I’m new to Auth0, so please be gentle :slight_smile:

We’re trying to use a custom template for our universal login. We created a custom domain, but when I run auth0 universal-login templates update, I get an error config.json file is missing.

Any thoughts on what could be going wrong?

Thanks in advance!

1 Like

Hi @vex,

Welcome to the Auth0 Community!

I understand you have experienced an error when trying to update your Universal Login page template.

After my investigation, I was not able to reproduce the same errors as you when using the Auth0 CLI.

When trying to call auth0 universal-login templates update, I got the unknown command "universal-login" for "auth0" error message.

From my experience, the config.json file is only needed for the Auth0 Deploy CLI and not the Auth0 CLI. Typically, you would make a request that would look something like the following:

a0deploy import -c=config.json --input_file=local/tenant.yaml

With that, could you please clarify if you are trying to update the Universal Login page templates on the Auth0 CLI or Auth0 Deploy CLI?

I look forward to your update.


1 Like

Hi Rueben, thanks for the quick reply!

Our ultimate goal is to hide Sign Up for some applications (but not others) in our tenant. We’re referencing an answer from this community post, which references the Universal Login Auth0 documentation.

One thing that confuses me is that the documentation says to use the auth0 branding command, but the Auth0 CLI tool doesn’t have that command (I’m referencing commands listed under “Available Commands”), and instead has auth0 universal-login. Do you know what’s going on?

Alright, it looks like the error went away with time (maybe it was a propagation thing), as today I’m able to use auth0 universal-login templates update to update the custom template, but the update doesn’t look like it’s been applied. The Auth0 documentation has a reference to “update the code” to use the custom domain for the Universal Login, but I don’t know where that would be. Any thoughts?

1 Like

Hi, guys, I’ve got the same error.
macOS: brew tap auth0/auth0-cli && brew install auth0
dann: auth0 universal-login templates update (or show)
error: config.json file is missing

Hi, Rueben!
It’s about Auth0 CLI

So, just to recap, I believe the main issue from this post ( “config.json file is missing”) is just resolved with time, but @ skirasirov, please add your experience!

I also figured out my second issue. We needed to update the URL that we point to in our app from the original domain to our custom domain.

1 Like

Hi @vex,

I’m glad everything is working now and thank you for sharing your solution with the rest of the Community!

Please reach out again if you have any additional questions.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.