Auth0 Home Blog Docs

Can't install Auth0 PHP packages with Laravel 6

I seem to be unable to install the auth0/login Composer package alongside laravel/framework ^6.0. I’ve tried several different version constraints with Auth0’s package, including ~5.0, ~6.0 (which doesn’t seem to exist yet), and dev-master.

Composer complains about unsatisfiable dependencies: “Your requirements could not be resolved to an installable set of packages.”

This despite the Github repo readme saying “Master targets Laravel 6 compatibility.” :thinking:

Hi there @bill.yanelli, welcome to the Auth0 Community!

When you get a chance can you share your composer.json file along with any console/log information you may have with the resulting error? Thanks in advance!

@James.Morrison - I’m having the same issue installing auth0/login on a fresh laravel 6.0 install.

composer require auth0/login:"~5.0"
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Conclusion: don't install auth0/login 5.2.0
    - Conclusion: don't install auth0/login 5.1.0
    - Conclusion: don't install auth0/login 5.0.2
    - Conclusion: don't install auth0/login 5.0.1
    - Conclusion: remove laravel/framework v6.0.3
    - Installation request for auth0/login ~5.0 -> satisfiable by auth0/login[5.0.0, 5.0.1, 5.0.2, 5.1.0, 5.2.0].
    - Conclusion: don't install laravel/framework v6.0.3
    - auth0/login 5.0.0 requires illuminate/support 5.* -> satisfiable by illuminate/support[5.0.x-dev, 5.1.x-dev, 5.2.x-dev, 5.3.x-dev, 5.4.x-dev, 5.5.x-dev, 5.6.x-dev, 5.7.17, 5.7.18, 5.7.19, 5.7.x-dev, 5.8.x-dev, v5.0.0, v5.0.22, v5.0.25, v5.0.26, v5.0.28, v5.0.33, v5.0.4, v5.1.1, v5.1.13, v5.1.16, v5.1.2, v5.1.20, v5.1.22, v5.1.25, v5.1.28, v5.1.30, v5.1.31, v5.1.41, v5.1.6, v5.1.8, v5.2.0, v5.2.19, v5.2.21, v5.2.24, v5.2.25, v5.2.26, v5.2.27, v5.2.28, v5.2.31, v5.2.32, v5.2.37, v5.2.43, v5.2.45, v5.2.6, v5.2.7, v5.3.0, v5.3.16, v5.3.23, v5.3.4, v5.4.0, v5.4.13, v5.4.17, v5.4.19, v5.4.27, v5.4.36, v5.4.9, v5.5.0, v5.5.16, v5.5.17, v5.5.2, v5.5.28, v5.5.33, v5.5.34, v5.5.35, v5.5.36, v5.5.37, v5.5.39, v5.5.40, v5.5.41, v5.5.43, v5.5.44, v5.6.0, v5.6.1, v5.6.10, v5.6.11, v5.6.12, v5.6.13, v5.6.14, v5.6.15, v5.6.16, v5.6.17, v5.6.19, v5.6.2, v5.6.20, v5.6.21, v5.6.22, v5.6.23, v5.6.24, v5.6.25, v5.6.26, v5.6.27, v5.6.28, v5.6.29, v5.6.3, v5.6.30, v5.6.31, v5.6.32, v5.6.33, v5.6.34, v5.6.35, v5.6.36, v5.6.37, v5.6.38, v5.6.39, v5.6.4, v5.6.5, v5.6.6, v5.6.7, v5.6.8, v5.6.9, v5.7.0, v5.7.1, v5.7.10, v5.7.11, v5.7.15, v5.7.2, v5.7.20, v5.7.21, v5.7.22, v5.7.23, v5.7.26, v5.7.27, v5.7.28, v5.7.3, v5.7.4, v5.7.5, v5.7.6, v5.7.7, v5.7.8, v5.7.9, v5.8.0, v5.8.11, v5.8.12, v5.8.14, v5.8.15, v5.8.17, v5.8.18, v5.8.19, v5.8.2, v5.8.20, v5.8.22, v5.8.24, v5.8.27, v5.8.28, v5.8.29, v5.8.3, v5.8.30, v5.8.31, v5.8.32, v5.8.33, v5.8.34, v5.8.35, v5.8.4, v5.8.8, v5.8.9].
    - don't install illuminate/support 5.5.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.16|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.17|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.2|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.28|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.33|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.34|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.35|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.36|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.37|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.39|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.40|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.41|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.43|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.5.44|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.6.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.1|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.10|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.11|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.12|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.13|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.14|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.15|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.16|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.17|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.19|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.2|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.20|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.21|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.22|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.23|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.24|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.25|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.26|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.27|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.28|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.29|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.3|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.30|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.31|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.32|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.33|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.34|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.35|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.36|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.37|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.38|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.39|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.4|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.5|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.6|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.7|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.8|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.6.9|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.7.17|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.7.18|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.7.19|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.7.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.1|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.10|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.11|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.15|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.2|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.20|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.21|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.22|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.23|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.26|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.27|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.28|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.3|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.4|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.5|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.6|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.7|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.8|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.7.9|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.8.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.11|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.12|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.14|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.15|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.17|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.18|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.19|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.2|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.20|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.22|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.24|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.27|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.28|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.29|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.3|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.30|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.31|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.32|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.33|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.34|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.35|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.4|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.8|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.8.9|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.1.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.2.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.3.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.4.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.1|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.13|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.16|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.2|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.20|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.22|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.25|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.28|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.30|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.31|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.41|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.6|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.1.8|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.19|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.21|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.24|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.25|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.26|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.27|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.28|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.31|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.32|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.37|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.43|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.45|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.6|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.2.7|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.3.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.3.16|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.3.23|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.3.4|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.4.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.4.13|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.4.17|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.4.19|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.4.27|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.4.36|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.4.9|don't install laravel/framework v6.0.3
    - don't install illuminate/support 5.0.x-dev|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.0.0|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.0.22|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.0.25|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.0.26|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.0.28|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.0.33|don't install laravel/framework v6.0.3
    - don't install illuminate/support v5.0.4|don't install laravel/framework v6.0.3
    - Installation request for laravel/framework (locked at v6.0.3, required as ^6.0) -> satisfiable by laravel/framework[v6.0.3].

I have the same issue install auth0 packages on laravel 6.0

I wanted to follow up @bill.yanelli, @nexstar, and @MelanieTirado. After talking with our SDK team, the supporting changes is within the master branch. There are times where the Master branch contains unreleased changes which appears to have happened in this case but is documented in the changelog.md. This should be officially released in the very near future.

However to get ahead of the official release you can leverage the master branch in Composer that would be something like this should help you move forward.

"repositories": [
        {
            "type": "vcs",
            "url": "https://github.com/auth0/laravel-auth0"
        }
    ],
    "require": {
        "auth0/laravel-auth0": "dev-master"
    }

Thanks!

Thank you @James.Morrison!

I added what you sent to composer.json in a test project and in the terminal I updated composer, but it throws me the following error:

The composer.json:
“name”: “laravel/laravel”,
“type”: “project”,
“description”: “The Laravel Framework.”,
“keywords”: [
“framework”,
“laravel”
],
“license”: “MIT”,
“require”: {
“php”: “^7.2”,
“fideloper/proxy”: “^4.0”,
“laravel/framework”: “6.0”,
“laravel/tinker”: “^1.0”,
“auth0/laravel-auth0”: “dev-master”
},
"repositories": [
{
“type”: “vcs”, “url”: “https://github.com/auth0/laravel-auth0
}
],
“require-dev”: {
“facade/ignition”: “^1.4”,
“fzaninotto/faker”: “^1.4”,
“mockery/mockery”: “^1.0”,
“nunomaduro/collision”: “^3.0”,
“phpunit/phpunit”: “^8.0”
},
“config”: {
“optimize-autoloader”: true,
“preferred-install”: “dist”,
“sort-packages”: true
},
“extra”: {
“laravel”: {
“dont-discover”: []
}
},
“autoload”: {
“psr-4”: {
“App\”: “app/”
},
“classmap”: [
“database/seeds”,
“database/factories”
]
},
“autoload-dev”: {
“psr-4”: {
“Tests\”: “tests/”
}
},
“minimum-stability”: “dev”,
“prefer-stable”: true,
“scripts”: {
“post-autoload-dump”: [
“Illuminate\Foundation\ComposerScripts::postAutoloadDump”,
@php artisan package:discover --ansi”
],
“post-root-package-install”: [
@php -r “file_exists(’.env’) || copy(’.env.example’, ‘.env’);””
],
“post-create-project-cmd”: [
@php artisan key:generate --ansi”
]
}
}

**How can I get the token? **

Thanks!

Hi,

We have the same issue as OP. Tried the hack offered by @James.Morrison to no avail. How long before we get an actual solution for Laravel 6? This is my first experience with Auth0 and it doesn’t bode well that we’re being asked to pull from a dev repo to support the current version of Laravel. Please advise.

Thanks!

@mel.norris - To clarify, we aren’t recommending that you use the master branch in a production application. But if you’re developing a Laravel 6 app or working on testing that update in a development branch yourself, that’s one way to get it working.

@MelanieTirado - It looks like your GitHub token is out of date. GitHub has a documentation page on that here

To everyone else waiting on this: we’re working on fixing the session handling in our Laravel module in a way that doesn’t require any breaking changes. This is taking a little longer than expected but this is a high priority to get out the door. This relies on a change to the underlying library but that’s close to release as well.

I would like to get all of this out in the same release this week. If it’s looking like those changes are going to take longer, I’ll cut a release with just the Laravel update. So, expect this to be updated by this Thursday at the latest.

We appreciate your patience :bowing_man:

1 Like

Just FYI for everyone waiting … 5.3.0 is released with Laravel 6 support and better session handling!


https://packagist.org/packages/auth0/login#5.3.0

Thanks again for your patience on this.

1 Like

Thanks @josh.cunningham!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.