Cannot read property 'office365Provisioned' of undefined


I’ve tried to implement this tutorial to authenticate my office 365 users from Google.
I followed every steps of this tutorial but when i tried to test it, i got this message form Micosoft:
Request Id: acd1d16f-4076-4a75-85a0-69aff03f2200
Correlation Id: 103f77b7-5790-4d92-a2c2-630814fe4ba1
Timestamp: 2020-04-12T22:26:42Z
Message: AADSTS20001: The sign-in response message does not contain an issued token.

And in my Auth0 logs, i got these errors: Cannot read property ‘office365Provisioned’ of undefined

Please could you help me fix this issue?


Based on the error message and overall result in Azure AD the cause of the issue may be the fact that one of your configured rules in the tenant is throwing an error (Cannot read property ‘office365Provisioned’ of undefined) due to assuming a property will be available somewhere where it is not.

The error in rules would trigger a failed login and an error response to be returned back to the service provider which being an error response would not include any tokens; just an error.

If you haven’t done so already you should review configured rules to see where that property may be being used without checking it is indeed available.