Overview
Some developers are still using the Auth0 WordPress Plugin with older versions that are no longer supported. Issues could arise because these versions have bugs or are simply behaving incorrectly. This article explains the reason for this and gives some tips on overcoming it.
Applies To
- Auth0 WordPress Plugin versions < 5
Cause
The Auth0 WordPress plugin has undergone some updates throughout the years, and the older versions are not being maintained, so certain bugs keep happening. Please see this link for more details.
The most recent bug raised by a customer was that upon trying to save some changes made to the plugin, there was no “Save Changes” button, so the way the Plugin was set up was definite.
Solution
As a solution, Auth0 recommends having the plugin up to date with the latest versions since these are updated and are being actively maintained. If any issues arise from any version starting with v5, please create a support ticket.
If there is any specific use case that requires the use of older versions, as a workaround, all settings can be accessed via the WordPress database. This would allow plugin users to customize the settings for specific use cases. For example, in v5 and older versions, the “Require Email Verification” toggle is gone because that feature is built-in by default and cannot be changed.