Auth0 not sending Email Verification emails

The docs say that auth0 automatically sends verification emails on signups by default. This options may have been changed by another user of our tenant. But I can’t seem to find this option to turn it back on. I know you can call the api to send verification emails, but I’m looking for auth0 to do it automatically after a sign up.

Does anyone know why this is not happening? Or where the setting is that controls this?


Hi @joshua.tanton,

Welcome to the Auth0 Community!

Yes, your tenant should be sending verification emails by default. Have you configured an email provider and make sure your verification email template is enabled.

Can you also please share why type of connection you are using? Database, social(google, facebook, etc), or otherwise?

Hi Dan,

Thanks for the reply, I will look into setting up the email provider and template. I’m fairly certain we haven’t done this yet.

Once this is setup, is there a way for me to only enable it for specific databases and/or applications. our tenant uses multiple databases across multiple apps. The app I’m specifically concerned about sending verification emails uses username/password databases as well as google and facebook social connections. It also uses an AD connection, but we would not require email verifications for this.


No, this is a global setting. If you want to customize email verification on a per-application basis, then you will need to handle the email and verification flow. You can use Actions to call your email provider.

Edit: Your social connections will require email verification.

Hi Dan,

this has helped. I’ve been able to call the tickets/email-verification api to get a verification link for my users which I will send in an email myself.
However, I can only seem to get it to work for my username/password database users. For my AD Connection I can’t seem to find the correct value for the provider field. Any ideas? I’ve Tried “NameOfActualConnection”, “Active Directory”, “Active Directory / LDAP”, “AD”, “LDAP”. All of these give mteh 400 bad request saying that the identity.provider property has an invalid value.

Any ideas?


I don’t have an AD/LDAP connection set up to test, but it should be the Connection Name you see in the connection settings. This:

So I was using this and it was failing. I got some error indicating I would need to update my AD connector.
But I realized this isn’t needed. I won’t need these links for users from the AD connection. So what I attempted to do was automatically mark these users as email_verified by using the PATCH api ({user_id}) with the following payload:
“email_verified” : “true”
However, I’ve come across two issues with this. The api itself returns a bad request error. When looking at the raw JSON of my AD users this property does not exist. Almost as if this field does not exist for AD accounts.

I found this topic that looks like it may answer this question. Can you take a look and see if it provides any insight?

1 Like

Hi Dan,

Yes we discovered this ourselves just 10 minutes ago when we will looking at our AD Connector (written by a different team member). This appears to have worked. After login the AD user is set to verified.



Glad you found a solution, and thank you for posting a follow up! Let us know if you have other questions.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.