Auth0 Home Blog Docs

Auth0 login on ipad not working for a Gatsby website, stays on callback URL

I’m having serious issues with Auth0, IOS and Gatsby. I have a website set up which has been built using a static site generator, Gatsby.

When I implement my own custom domain for login then browsers on desktops work fine. However, on either IOS iphone or ipad the site will NOT let me log in, and will just stay on the callback URL.

When I remove my own custom domain and instead use Auth0’s default domain, then I can log in on IOS iphone only but still NOT on ipad.

Does anyone have any suggestions on what I can do to resolve any of the above?

I presume you also followed https://auth0.com/blog/securing-gatsby-with-auth0/ like myself. I too have an issue with iPad and auth0 using a custom domain. The callback page just doesnt grab that accessToken.

Been remote debugging using Safari usb to the iPad. Strange, if i run gatsby with: gatsby develop -H 0.0.0.0
And then look at my local IP (eg, 192.168.15.7:8000) and add that to the auth0 callback and web origin i can then bring up the local network hosted website on my iPad to the locally running gatsby app. I also connect using Safari remote inspector. All works just fine, i get my access token and silent auth all work fine.
Deploy online… to (for example) mywebsite.com with a custom auth0 domain of auth.mywebsite.com
auth.parseHash(setSession()) just always returns null.

But. Revert the authjs code to call the auth0 domain instead of my custom eg, mytenant.auth0.com and it works perfectly.

For more info i have another domain (eg anotherwebsite.com) that uses the same client, this works on iPad fine using either the custom auth0 mapped domain or the provided auth0 domain.

So my intuition is telling me its something to do with logging in (on iPad only os 13.2.2) when you are calling from the root domain that also matches part of the custom auth0 domain.

Recap:
mywebsite.com calling auth.mywebsite.com no access token
mywebsite.com calling mytenant.auth0.com gets access token
anotherwebsite calling either auth.mywebsite.com or mytenant.auth0.com gets access token

Just checking in on this one. Any thoughts?

Hey @steve1,

I don’t have an environment setup to test this, but we can walk through some steps to try and narrow things down.

Can you send me your tenant name and the effected app id in a DM?

In addition, you can look at your Auth0 logs and see if you are getting an error in the transaction. Are you getting any errors in the app?

In addition, I am reaching out to some other folks on the subject. Thanks for your patience.

Dan

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.