Auth0 login error in iOS/iPhone after OS upgrade to 14.6

We have successfully integrated Auth0 Universal Login into two apps available on iOS and Android.

Everything has been working flawlessly for months, but this week we have started to encounter some issues on iOS. It seems to be specifically linked to the OS upgrade to 14.6.

Users who have upgraded try to login and receive the error - “We’re sorry, something went wrong when attempting to log in”.

This is despite the user entering the correct credentials (we have a custom message if they enter the incorrect credentials).

Despite this error, nothing is shown in logs. We have found that after 10 attempts the user is blocked, and this does show in logs, but the 10 failed attempts to login are not shown.

Is anyone else experiencing this issue? Any suggestions on a fix? Believe it may be related to the security changes in Safari on iOS/mobile after the update.

Note - we have tried logging on with the same user credentials on other devices that are not yet on 14.6 and they still work and function as expected. The same applies to android where the same users are able to login without any problems.

We have tried removing all customisations from the login and return to the default lock, but the same error shows.

Only iPhone on 14.6 we’ve managed to get it to work on is a 6s, newer models from XR onwards seem to have the issue.

Any ideas/assistance would be greatly appreciated!

UPDATE: Managed to get an XR to work on 14.6 after a fresh install… Not a practical option for most of our users though so hoping to avoid that as a resolution.

We are having this exact issue with a user and cannot get this solved. Has anyone got a firm idea of why this occurs for some users on iOS 14.6?