Auth0 Home Blog Docs

Auth0 does not work on the checkout screen

When logging directly into the payment screen, if there is a WooCommerce order parameter (wc order), the Wordpress login form will be displayed instead of the button to the Auth0 login screen.

How can I display the Auth0 login button under the above conditions?

Good morning @kei_watanabe and welcome to the Auth0 Community!

When you get a chance can you share a bit more detail on what’s occurring here? A workflow paired screenshots with a HAR file would help. If you are able to snag a HAR file, tenant name, or any details that has sensitive information in it you can direct message me and we can take a look together. Be sure to select “Preserve log” to catch redirects and scrub the file of user passwords before passing. Thanks in advance!

Sorry for the lack of explanation.

I am currently using WooCommerce at Wordpress.com.
I am trying to manage login of WooCommerce with plug-in “login by auth0”.

WooCommerce function
“My account” → “Orders” → “Actions” → “Pay”

↓ I want to go directly to the URL of the above “Pay” button from another screen.

https://xxxxxxxxxx.com/checkout/order-pay/6939/?pay_for_order=true&key=wc_order_891vMjsnhnnGr

There is no problem if you are logged in to Auth0,
if “wc_order_891vMjsnhnnGr” is included in the URL, the login button (“Login By Auth0 Plugin” is displayed?)
WooCommerce ’s standard login screen is displayed.

Setting “Original login form for wp-login.php” to “None” did not work.
Do I need other settings?

I apologize for the delay as I’ve been out of office. I want to make sure I understand currently because I may be off base here.

In the above described scenario, I understand it works as expected if the user is logged in and the session is active. My question is how would it work with the url if the user hasn’t already logged in and started a session since the user is being passed in the URL in the above example?

Thank you for such a wonderful article and sharing. God bless you.! MyKFCExperience

1 Like