Auth0 Allowed Logout URLs only working with 1st URL in the list

Hi all,

Currently I’ve configured a couple of url’s in the Allowed Logout Url’s in a Auth0 application.

But when the user is logging out only taking the first URL which is mentioned in the Allowed Logout URLs though I’ve mentioned returnTo parameter with the exact URL.

Is there anything I’m configuring wrongly?

Hey there @AbdYashar07 !
Apologies for the late replay on that.

Logout URLs can be set on 2 different layers in the Auth0 dashboard (tenant level and a single app level).

When calling logout with auth0-react-js you can specify two properties as described here. Does your logout request includes both the clientID and the returnTo parameter, like below?


Please note:

If the client_id parameter is included, the returnTo URL that is provided must be listed in the Application’s “Allowed Logout URLs” in the Auth0 dashboard. However, if the client_id parameter is not included, the returnTo URL must be listed in the “Allowed Logout URLs” at the account level in the Auth0 dashboard.

More info on registering logout URLs in Auth0:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.