Auth0 Home Blog Docs

Auth 0 SSO integration for SharePoint 2013 With Custom IDP-Login Issue


#1

Hi Team,

We are trying to create a POC for our client to Migrate from ACS to Auth 0 as ACS is going to be deprecated by end of this year. Need your help in doing so as we are stuck at below mentioned issue.

Could you please help us in this regard.

I have created trial tenant in Auth 0.

Configured SharePoint 2013 on premise in SSO Integrations in Auth 0. Followed the instructions from this blog(Click Here).

Configured Custom WS-Federation Identity Provider in Auth 0. Followed the instructions from this blog(Click Here).

When trying to login to SharePoint Site after the configurations, please find the attached error message from our custom Identity Provider.

Also checked the URL generated by Auth 0 while signing in and compared with Microsoft ACS generated URL. WREPLY parameter is missing in Auth O generated URL.

ACS generated URL for Custom Identity Provider.

https://profiledev.ecommerce.infra/Login/Signin?

ReturnUrl=/?

wa=wsignin1.0

&wtrealm=https://xxx-aac.accesscontrol.windows.net/

&wreply=https://xxx-aac.accesscontrol.windows.net/v2/wsfederation

&wctx=cHI9d3NmZWRlcmF0aW9uJnJtPWh0dHAlM2ElMmYlMmZ3d3cubGVzb25hbC5jb20lMmYmcnk9JmN4PWh0dHAlM2ElMmYlMmZ3d3cubGVzb25hbC5jb201

Auth 0 generated URL for Custom Identity Provider.

https://profiledev.ecommerce.infra/Login/Signin?

ReturnUrl=/?

wctx=sN_nk2sNoTdX3QnKPZAH56s_HVjmHvYp

&wtrealm=urn:auth0:testingformt

&wa=wsignin1.0

Let me know if you need any additional information.

Ravi Prasad G