Auth0 Home Blog Docs

Issue with AWS SAML


#1

I made an app and enabled SAML using AWS. It gives me a Identity Provider Login URL:

https://domain-name.auth0.com/samlp/clientid

And in the end it says that

“Alternatively, you can add a connection parameter:”

The issue is that I am logging in my portal using Auth0 but need amazon services using SAML. If I use the above URL everything works fine. For the portal, I have the following configuration file:

const Auth0Config = {
domain: ‘my-tenant.auth0.com’,
clientID: ‘my-client-id’,
allowedConnections: [‘Username-Password-Authentication’],
rememberLastLogin: true,
language: ‘en’,
closable: true,
options: {
auth: {
autoParseHash: true,
redirect: true,
redirectUrl: window.location.href + ‘auth0loginCallback’
},
languageDictionary: {
title: ‘Auto Labs.’,
emailInputPlaceholder: ‘demo@gmail.com’,
passwordInputPlaceholder: ‘demodemo’
},
}
};

The client id is of the app which has SAML integrated.

But when I do this, I do not get access to the AWS services (if I use the given " Identity Provider Login URL" it does grant me access to the AWS services).

Why is this happening?


Issue with Auth0 and AWS (SAML)